Формула енд в excel

Формула енд в excel

На этой страничке описаны девять функций рабочего листа, которые используются для проверки типа значения или ссылки.

Каждая из этих функций проверяет тип значения и возвращает значение ИСТИНА или ЛОЖЬ в зависимости от типа. Например, функция ЕПУСТО возвращает логическое значение ИСТИНА, если проверяемое значение является ссылкой на пустую ячейку; в противном случае возвращается логическое значение ЛОЖЬ.

ЕПУСТО(значение)
ЕОШ(значение)
ЕОШИБКА(значение)
ЕЛОГИЧ(значение)
ЕНД(значение)
ЕНЕТЕКСТ(значение)
ЕЧИСЛО(значение)
ЕССЫЛКА(значение)
ЕТЕКСТ(значение)

Значение — это проверяемое значение. Значение может быть пустой ячейкой, значением ошибки, логическим значением, текстом, числом, ссылкой или именем объекта любого из перечисленных типов.

Функция Возвращает ИСТИНА, если
ЕЛОГИЧ Значение ссылается на логическое значение.
ЕНД Значение ссылается на значение ошибки #Н/Д (значение недоступно).
ЕНЕТЕКСТ Значение ссылается на любой элемент, который не является текстом. (Заметим, что функция возвращает ИСТИНА, если значение ссылается на пустую ячейку).
ЕОШ Значение ссылается на любое значение ошибки, кроме #Н/Д.
ЕОШИБКА Значение ссылается на любое значение ошибки (#Н/Д, #ЗНАЧ! , #ССЫЛ! , #ДЕЛ/0! , #ЧИСЛО! , #ИМЯ? или #ПУСТО!).
ЕПУСТО Значение ссылается на пустую ячейку.
ЕССЫЛКА Значение ссылается на ссылку.
ЕТЕКСТ Значение ссылается на текст.
ЕЧИСЛО Значение ссылается на число.

Аргумент этих функций не преобразуется. Для большинства других функций, например, если в качестве аргумента требуется число, то текстовое значение «19» преобразуется в число 19. Однако в формуле ЕЧИСЛО("19") «19» не преобразуется из текста в число, и функция ЕЧИСЛО возвращает значение ЛОЖЬ.

Эти функции полезны в формулах и макросах для проверки результатов вычислений. Комбинируя эти функции с функцией ЕСЛИ, можно локализовать ошибки в формулах (см. следующие примеры).

Формула Описание (результат)
=ЕЛОГИЧ(ИСТИНА) Проверяет, является ли значение ИСТИНА логическим значением (ИСТИНА)
=ЕЛОГИЧ("ИСТИНА") Проверяет, является ли значение «ИСТИНА» логическим значением (ЛОЖЬ)
=ЕЧИСЛО(4) Проверяет, является ли значение 4 числом (ИСТИНА)
A B C
1 Данные Формула Описание (результат)
2 Золото =ЕПУСТО(A2) Проверяет, является ли ячейка A2 пустой (ЛОЖЬ)
3 Регион1 =ЕОШИБКА(A4) Проверяет, является ли #ССЫЛ! сообщением об ошибке (ИСТИНА)
4 #ССЫЛ! =ЕНД(A4) Проверяет, является ли #ССЫЛ! сообщением об ошибке #Н/Д (ЛОЖЬ)
5 330,92 =ЕНД(A6) Проверяет является ли #Н/Д сообщением об ошибке #Н/Д (ИСТИНА)
6 #Н/Д =ЕОШ(A6) Проверяет, является ли #Н/Д сообщением об ошибке (ЛОЖЬ)
7 =ЕЧИСЛО(A5) Проверяет, является ли значение 330,92 числом (ИСТИНА)
8 =ЕТЕКСТ(A3) Проверяет, является ли значение «Регион1» текстом (ИСТИНА)

Наиболее часто мне приходится применять функцию ЕНД() в комбинации с функцией ЕСЛИ() в случае если функция ВПР() выдает ошибку типа #Н/Д. Пример такого применения можно посмотреть здесь.

Функция ЕНД() в MS EXCEL

​Смотрите также​ с пунктом​ наоборот. В формулах,​ Значения в первой​ПОИСКПОЗ("Апельсины";C2:C7;0)​ пропусками в таблице нет,​Дополнительные сведения см. в​

Синтаксис функции

​ находить в списке​​ получить с помощью​

​находится любое другое​​А1​=ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10))​ можно сделать с​ функции И(), т.е.​

​ в большой таблице​Календарь​ ввести формулу =ЕСЛИ(ЕНД(E2);"ОШИБКА!";E2)​Функция ЕНД(), английский вариант​Мастер подстановок​ которые создает мастер​ строке должны быть​ищет значение "Апельсины"​ поэтому функция ВПР​ разделе, посвященном функции​ и автоматически проверять​ формулы массива​ число кроме 0,​отрицательного значения, положительного​Т.е. если в​

​ помощью функции =ЕСЛИ(ЕНД(ПОИСКПОЗ(A8;$E$17:$E$28;0));"";"Да!")​​ строки совпадают, когда​​ (см. файл примера). ​(см. Файл примера).​Теперь если в ячейке ​ ISNA(), проверяет на​

​и нажмите кнопку​​ подстановок, используются функции​​ отсортированы по возрастанию.​ в диапазоне C2:C7.​ ищет первую запись​

Ближайший рабочий день в MS EXCEL с учетом праздников и переносов

​ ВПР.​ их правильность. Значения,​=СУММ(ЕСЛИ(A6:A11>10;A6:A11))​ то формула вернет​ значения или 0,​ ячейке​Найденные строки можно выделить​ значения из обоих​Строки считаются совпадающими, когда​Создадим через Диспетчер имен​Е2 ​ равенство значению #Н/Д​ОК​ ИНДЕКС и ПОИСКПОЗ.​

​В приведенном выше примере​ Начальную ячейку не​ со следующим максимальным​Что означает:​ возвращенные поиском, можно​

​(для ввода формулы​ Бюджет превышен. Такой​ то можно записать​A1​ с помощью Условного​ столбцов совпадают с​ их значения в​ (Формулы/ Определенные имена/​содержится ошибка #Н/Д, то будет​ (значение недоступно) и​​.​​Щелкните ячейку в диапазоне.​

​ функция ГПР ищет​ следует включать в​ значением, не превышающим​=ИНДЕКС(нужно вернуть значение из​
​ затем использовать в​
​ в ячейку вместо​

​ подход удобен, когда​ следующую формулу:​содержится значение >100,​ форматирования.​ соответствующими значениями искомых​​ обоих столбцах попарно​ Диспетчер имен) два​​ выведено слово ОШИБКА!​
​ возвращает в зависимости​

​Следуйте инструкциям мастера.​​На вкладке​ значение 11 000 в строке 3​
​ этот диапазон.​
​ 6. Она находит​
​ C2:C10, которое будет​

Поиск заданных строк в таблице MS EXCEL

​ вычислениях или отображать​ENTER​ проверяется равенство значения​=ПРОСМОТР(A1;<-1E+307;0;1E-307>;<"<>0">)​ то суммирование ведется​

​Функция ЕСЛИ(), английский вариант​ строк. Функция СУММПРОИЗВ()​ совпадают.​ динамических диапазона:​ (см. файл примера).​ от этого ИСТИНА​

Читайте также:  Цап denon da 300usb

​К началу страницы​Формулы​ в указанном диапазоне.​

​1​ значение 5 и возвращает​ соответствовать ПОИСКПОЗ(первое значение​ как результаты. Существует​

​нужно нажать​ нулю.​или, если требуется вместо​

​ по столбцу​ IF(), используется при​ складывает результат перемножения​Для поиска совпадений будем​Праздники =СМЕЩ(календарь!$A$3;;;СЧЁТЗ(календарь!$A$3:$A$31)) и​Предположим, что счет за​ или ЛОЖЬ.​Мур​в группе​ Значение 11 000 отсутствует, поэтому​ — это количество столбцов,​ связанное с ним​ "Капуста" в массиве​ несколько способов поиска​CTRL+SHIFT+ENTER​EXCEL содержит также другие​ текстовых значений вывести​

​B​ проверке условий. Например,​ и использована вместо​ использовать формулу =СУММПРОИЗВ((B17=B$8:B$12)*(C17=C$8:C$12)) Формулу разместим​Рабочие_дни =СМЕЩ(календарь!$D$3;;;СЧЁТЗ(календарь!$D$3:$D$31))​ продукцию нужно выставлять​ЕНДзначение​: Добрый день участникам​Решения​ она ищет следующее​ которое нужно отсчитать​ имя​ B2:B10))​ значений в списке​)​ функции, которые можно​ формулы, можно использовать​, а если меньше,​ =ЕСЛИ(A1>100;"Бюджет превышен";"ОК!"). В​ СУММ() лишь для​

​ в столбце D.​Если дата попадает на​ только в рабочие​)​ форума.​выберите команду​ максимальное значение, не​ справа от начальной​Алексей​Формула ищет в C2:C10​ данных и отображения​Теперь подсчитаем количество вхождений​

​ применять для анализа​​ ссылки на диапазон​ то по столбцу​ зависимости от значения​

​ того, чтобы не​Формула работает следующим образом.​ субботу (не рабочую),​ дни, несмотря на​

​Значение​В приложенном примере​Подстановка​ превышающее 11 000, и возвращает​ ячейки, чтобы получить​.​

​ первое значение, соответствующее​ результатов.​ чисел больше 10​

Функция ЕСЛИ() в MS EXCEL

​ данных с использованием​ ячеек (содержащих формулы)​С​ в ячейке​ использовать формулы массива.​ Выражение B17=B$8:B$12 сравнивает текущее​​ воскресенье или праздник,​​ дату доставки. Напишем​- ссылка на​ необходимо в ячейках​

Синтаксис функции

​ столбец, из которого​

​Дополнительные сведения см. в​​ значению​Поиск значений в списке​ в диапазоне ячеек​
​ условий. Например, для​
​=ПРОСМОТР(A24;<-1E+307;0;1E-307>;A27:A29) (см. файл примера)​.​​А1​​Для примера рассмотрим строку​ значение первого столбца​ то нижеследующая формула​ формулу, которая определяет:​ ячейку или результат​ E9:E12 получить значения​

​Если команда​Дополнительные сведения см. в​ возвращается значение. В​
​ разделе, посвященном функции​
​Капуста​ по вертикали по​​A6:A11​​ подсчета количества вхождений​Третий аргумент функции не​В EXCEL 2007 в​​результат формулы будет​​ 18 (2-я строка​ большой таблицы со​​ возвращает дату​​ если дата доставки​

Вложенные ЕСЛИ

​ вычисления выражения, которое​ из ячеек​​Подстановка​​ разделе, посвященном функции​ этом примере значение​ ВПР.​(B7), и возвращает​ точному совпадению​
​=СЧЁТЕСЛИ(A6:A11;">10"). Аналогичный результат​ чисел в диапазоне​

​ обязателен, если его​ качестве значений аргументов​ либо "Бюджет превышен"​

​ в большой таблице).​ всеми значениями первого​

​следующего понедельника, точнее следующего​

​ попадает на выходной​ необходимо проверить.​​K9:K30​​недоступна, необходимо загрузить​

​ ГПР.​ возвращается из столбца​К началу страницы​​ значение в ячейке​​Поиск значений в списке​ (2) можно получить​ ячеек используется функция​ опустить, то функция​

​ либо "ОК!".​ Первое и второе​ столбца искомых строк,​ рабочего дня​ или праздничный день,​

​Функция ЕНД() позволяет обработать​

Опущен третий аргумент [значение_если_ложь]

​Самостоятельно придумать формулу,​ надстройка мастера подстановок.​К началу страницы​ D​Для выполнения этой задачи​ C7 (​
​ по вертикали по​
​ с помощью формулы массива​​ СЧЁТЕСЛИ(), а для​​ вернет значение ЛОЖЬ​можно для построения​Функция ЕСЛИ()относится к наиболее​

Вместо ИСТИНА или ЛОЖЬ в первом аргументе введено число

​ выражения вернут массивы <ЛОЖЬ:ИСТИНА:ИСТИНА:ЛОЖЬ:ЛОЖЬ>​ и возвращает массив​
​:​
​ то дата счета​ ошибку #Н/Д. Откуда берется​​ к своему стыду,​​Загрузка надстройки мастера подстановок​
​Примечание:​
​Продажи​

​ используются функции СМЕЩ​​100​​ приблизительному совпадению​=СЧЁТ(ЕСЛИ(A6:A11>10;A6:A11))​ сложения значений, удовлетворяющих​ (если условие не​ более сложных проверок​ часто используемым функциям.​ и <ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ЛОЖЬ>соответственно. После​

Связь функции ЕСЛИ() с другими функциями использующие условия

​ логических значений <ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ>. 5​=ЕСЛИ(ЕНД(ВПР(A2;Рабочие_дни;1;ЛОЖЬ));РАБДЕНЬ(A2-1;1;Праздники);A2)​ – следующий понедельник​ эта ошибка? Некоторые функции,​ не смог. Подозреваю,​Нажмите кнопку​ Поддержка надстройки "Мастер подстановок"​.​ и ПОИСКПОЗ.​).​Поиск значений по вертикали​Теперь, когда принцип понятен,​

​ определенным условиям, используется​ выполнено).​ использовать до 64​ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])​ попарного перемножения элементов​ значений ЛОЖЬ означает,​Другая формула возвращает дату​

​ (или прошедшая пятница).​ например ПРОСМОТР(), ПОИСКПОЗ() или ВПР() могут вернуть​​ там что-то с​​Microsoft Office​

​ в Excel 2010​К началу страницы​Примечание:​Дополнительные сведения см. в​ в списке неизвестного​ с помощью функции​ функция СУММЕСЛИ().​
​=ЕСЛИ(A1>100;"Бюджет превышен")​
​ вложенных друг в​Лог_выражение​​ массивов, он будет​​ что значение 1,2​​прошедшей пятницыточнее последнего рабочего​​ Решение также учитывает​

​ ошибку #Н/Д (значение​ массивом завязано.​, а затем —​​ прекращена. Эта надстройка​​Для выполнения этой задачи​ Данный метод целесообразно использовать​ разделах, посвященных функциям​
​ размера по точному​

​ ЕСЛИ() можно конструировать​Функция ЕСЛИ(), как альтернативный​Если в ячейке​ друга функций ЕСЛИ().​ — любое значение или​ преобразован в <0:0:1:0:0>. Т.е.​ из В17 не​ дня перед датой​
​ рабочие субботы.​

Читайте также:  Подключение камеры к arduino

Поиск значений в списке данных

​ недоступно). Значение ошибки #Н/Д​Заранее благодарен.​ кнопку​ была заменена мастером​ используется функция ГПР.​ при поиске данных​ ИНДЕКС и ПОИСКПОЗ.​ совпадению​ и другие формулы​ вариант, может быть​A1​=ЕСЛИ(A1>=100;"Бюджет превышен";ЕСЛИ(A1>=90;"Крупный проект";ЕСЛИ(A1>=50;"Средний​ выражение, принимающее значения​ строка 18 совпадает​ найдено в диапазоне B$8:B$12,​=ЕСЛИ(ЕНД(ВПР(A2;Рабочие_дни;1;ЛОЖЬ));​Решение этой задачи без​ не очень информативно,​Alex_ST​Параметры Excel​

В этой статье

​ функций и функциями​ См. пример ниже.​ в ежедневно обновляемом​

​К началу страницы​Поиск значений в списке​ с условиями. Например,​

​ также использована для​содержится значение 1,​ проект";"Малый проект ")))​ ИСТИНА или ЛОЖЬ.​

​ с третьей искомой​ состоящем из 5​ЕСЛИ(НЕ(ЕНД(ВПР(A2-1;Рабочие_дни;1;ЛОЖЬ)));A2-1;РАБДЕНЬ(A2+1;-1;Праздники));​

​ учета праздников и​ поэтому вместо значения​: Мурат,​

​и выберите категорию​ для работы со​Функция ГПР выполняет поиск​

Поиск значений в списке по вертикали по точному совпадению

​ внешнем диапазоне данных.​Для выполнения этой задачи​ по горизонтали по​ нахождение минимального значения​ подсчета и сложения​

Примеры функции ВПР

​ то вышеуказанная формула​Вышеуказанную формулу можно усложнять​=ЕСЛИ(A1>=100;"Бюджет превышен";"ОК!")​

Примеры функций ИНДЕКС и ПОИСКПОЗ

​ строкой. Функция СУММПРОИЗВ() вернет 1.​

​ значений, т.к. значение​A2)​ переносов рассмотрено в​ #Н/Д можно обработать,​вы же уже​

​Надстройки​ ссылками и массивами.​ по столбцу​​ Известна цена в​​ используется функция ВПР.​ точному совпадению​ среди чисел больше​​ значений с использованием​​ вернет значение ЛОЖЬ.​

​ и дальше, но​Т.е. если в​СОВЕТ​

​ не встречается в​

Поиск значений в списке по вертикали по приблизительному совпадению

​Найдем заданные строки в​ статье Ближайший рабочий​

​ т.е., например, заменить​​ не новичок! Не​.​В Excel 2007 мастер​

​Продажи​ столбце B, но​Важно:​Поиск значений в списке​ 10:​ условий. Ниже приведены​​Т.к. значение ЛОЖЬ эквивалентно​​ есть другие подходы:​ ячейке​: Для просмотра промежуточных​ первом столбце искомых​ таблице. Строки состоят​ день.​ #Н/Д на слово "Ошибка"​ нарушайте правил форума.​В поле​​ подстановок создает формулу​​и возвращает значение​

​ неизвестно, сколько строк​ Значения в первой​ по горизонтали по​

Поиск значений по вертикали в списке неизвестного размера по точному совпадению

​A1​​ вычислений воспользуйтесь клавишей​ строк.​ из 2-х столбцов,​В этой статье добавим​ или другое информационное​ Назовите правильно тему,​Управление​ подстановки, основанную на​ из строки 5 в​ данных возвратит сервер,​ строке должны быть​

​ приблизительному совпадению​​Предположим, что требуется найти​Пусть данные находятся в​=ЕСЛИ(0;"Бюджет превышен";"ОК!")​

​ превышен">)​​содержится значение большее​​ F9.​Аналогично, второе выражение ищет​ значения могут быть​ два перечня дат:​ сообщение типа "Значение​

​ а то её​​выберите значение​ данных листа, содержащих​ указанном диапазоне.​ а первый столбец​ отсортированы по возрастанию.​Создание формулы подстановки с​ внутренний телефонный номер​ диапазоне​или (если в​​=ВПР(A1;A3:B6;2)​​ или равное 100,​

​С помощью формулы массива =ПОИСКПОЗ(1;(B17=B$8:B$12)*(C17=C$8:C$12);0) найдем​

Поиск значений в списке по горизонтали по точному совпадению

​ совпадения во втором​ любыми.​ Праздники, т.е. праздничные​

​ не найдено" или​ Серж залочит.​​Надстройки Excel​​ названия строк и​Дополнительные сведения см. в​ не отсортирован в​

​В приведенном выше примере​ помощью мастера подстановок​ сотрудника по его​

Поиск значений в списке по горизонтали по приблизительному совпадению

​ ячейке​Для функции ВПР() необходимо​

​ то формула вернет​​ номер искомой строки.​ столбце. Далее, значения​Пусть имеется перечень из​

​ дни, которые попадают​ "Введите другое число".​nilem​и нажмите кнопку​ столбцов. С помощью​ разделе, посвященном функции​ алфавитном порядке.​ функция ВПР ищет​ (только Excel 2007)​

​ идентификационному номеру или​(см. файл примера)​A1​

​ создать в диапазоне​

Создание формулы подстановки с помощью мастера подстановок (только Excel 2007)

​ ОК!, а если​​ Формулу разместим в​ попарно перемножаются (при​ 5 строк, которые​ на рабочие и​Например, если в ячейке​: Без массива (без​Перейти​

​ мастера подстановок можно​ ГПР.​C1​ имя первого учащегося​Для решения этой задачи​ узнать ставку комиссионного​Подсчитаем сумму значений, которые​содержится значение 0)​A3:B6​ нет, то Бюджет​ столбце Е.​ этом ЛОЖЬ преобразуется​ требуется найти в​ Рабочие_дни, т.е. перенесенные​Е2​

​.​​ найти остальные значения​​К началу страницы​​ — это левая верхняя​​ с 6 пропусками в​​ можно использовать функцию​​ вознаграждения, предусмотренную за​

​ больше 10 с​​=ЕСЛИ(A1;"Бюджет превышен";"ОК!")​​таблицу значений:​ превышен.​

​Также для каждой искомой​

​ в 0, а​​ таблице MS EXCEL.​ ​ рабочие дни, которые​содержится ошибка #Н/Д,​​)​​В области​​ в строке, если​​Для выполнения этой задачи​

​ ячейка диапазона (также​​ диапазоне A2:B7. Учащихся​​ ВПР или сочетание​​ определенный объем продаж.​​ помощью функции СУММЕСЛИ(),​​вернут ОК!​​Если требуется вывести разный​

Читайте также:  Какой язык программирования низкоуровневый

​В качестве аргументов функции,​​ строки можно определить,​​ ИСТИНА в 1).​ Предполагается, что строки​​ попадают на субботу.​​ то в любой другой​​=ЕСЛИ(ЕНД(ВПР(A9;$G$9:$K$30;5;0));"";ВПР(A9;$G$9:$K$30;5;0))​​Доступные надстройки​

​ известно значение в​

​ используется функция ГПР.​

Формула ЕНД (Формула ЕНД и ВПР)

​ называемая начальной ячейкой).​​ с​ функций ИНДЕКС и​
​ Необходимые данные можно​ записав =СУММЕСЛИ(A6:A11;">10"). Аналогичный​Если в ячейке​ текст в случае​
​ могут участвовать формулы,​
​ если она в​ Знак умножения эквивалентен​ не повторяются.​ Перечни разместим на​ пустой ячейке можно​
​в яч. Е9​

​установите флажок рядом​​ одном столбце, и​
​Важно:​Формула​6​ ПОИСКПОЗ.​ быстро и эффективно​ результат (23) можно​

​A1​​ наличия в ячейке​ например:​​ большой таблице. Это​
​ в данном случае​
​Будем искать эти строки​

Функция ЕНД в Excel используется для проверки ячеек или выражений, передаваемых в качестве аргумента, и возвращает логическое значение ИСТИНА. Например, если ячейка содержит код ошибки #Н/Д или результатом вычисления выражения, переданного в качестве аргумента, является код ошибки #Н/Д. В противном случае результатом выполнения данной функции является логическое ЛОЖЬ.

Суммирование количества ошибок в ячейках Excel

Примеры использования функции ЕНД в Excel. Данная функция принадлежит к категории «Проверка свойств и значений» – функций Excel (нелогические функции для проверки условий). Она удобна при проведении сложных расчетов с ветвлением логики. Например, при отсутствии ошибки будет выполнено действие_1, в противном случае – действие_2.

Пример 1. В таблице содержатся данные о товарах и их количестве. Данные были получены из СУБД, если количество единиц товаров равно нулю, в таблице Excel данная информация отобразилась в виде кода ошибки #Н/Д. Определить число наименований товаров, которых нет в наличии.

Вид таблицы данных:

Для расчета используем следующую запись (формула массива CTRL+SHIFT+Enter):

Функция ЕНД принимает сразу диапазон ячеек B3:B13 в качестве аргумента, поскольку используется формула массива. Двойное отрицание «—» необходимо для явного преобразования логических значений к числовым данным (ИСТИНА – 1, ЛОЖЬ – 0). Функция СУММ суммирует элементы полученного массива из нулей и единиц. В результате получаем:

В результате мы получили число равно количеству ошибок #Н/Д в столбце B.

Как получить первое значение ячейки вместо ошибки Н/Д в Excel

Пример 2. В таблице содержится диапазон ячеек со случайными числами, отсортированными в порядке возрастания. Найти ближайшее число из данного диапазона заданному с помощью функции ПРОСМОТР. Известно, если искомое число меньше первого значения в диапазоне, будет выведен код ошибки #Н/Д. Обработать данную ситуацию так, чтобы вместо кода ошибки выводился первый элемент массива.

Вид таблицы данных:

Для поиска числа 1 используем следующую запись:

Функция ЕНД анализирует результат выполнения функции ПРОСМОТР. Если в качестве первого аргумента ПРОСМОТР передано числовое значение, которое меньше значения первого элемента просматриваемого диапазона, будет сгенерирован код ошибки #Н/Д и будет выполнено выражение, переданное в качестве аргумента значение_если_истина функции ЕСЛИ. В противном случае (искомое число находится в диапазоне массива или превышает значение его последнего элемента), выполнится выражение, переданное в качестве аргумента значение_если_ложь .

Как видно, ошибка #Н/Д не выводится, а вместо нее первое значение ячейки просматриваемого столбца.

Описание синтаксиса и параметров функции ЕНД в Excel

Функция ЕНД имеет следующую синтаксическую запись:

Единственным и обязательным для заполнения аргументом рассматриваемой функции является значение. Он принимает ссылки на ячейки, текстовые, числовые, логические данные, а также имена.

  1. Преобразование типов данных для значений, переданных в качестве аргумента функции ЕНД, не выполняется. Например, число «99» указанное в кавычках, будет рассматриваться как текстовые данные. Если в качестве аргумента была передана строка «#Н/Д», ЕНД вернет значение ЛОЖЬ. Если ячейка содержит код ошибки #Н/Д, функция ЕНД, получившая ссылку на данную ячейку в качестве аргумента, вернет – ИСТИНА.
  2. Данная функция обычно используется в комбинации с ЕСЛИ и другими функциями для проверки выражения для своевременной проверки результатов вычислений и перехвата возможной ошибки.
  3. Код ошибки #Н/Д генерируют функции в случаях, когда в формулах используются недопустимые значения. Распространенные примеры:
  • при использовании функций для поиска данных (ПОИСКОП, ВПР и других), если в качестве аргумента «искомое_значение» было введено несуществующее;
  • при использовании формул массивов, если длина массива результатов превышает длину исходных массивов;
  • если при использовании функции не были указаны один либо нескольких аргументов, обязательных для заполнения.
Ссылка на основную публикацию
Установка виндовс зависла на начало установки
Если вы решили переустановить или установить операционную систему, но начало установки Windows 7 зависает, то в этой статье, думаю, вы...
Тс 6 силы в механике
Тест по физике Силы в механике для 10 класса с ответами. Тест включает в себя 2 варианта. В каждом варианте...
Тульские двери металлические отзывы
Рады представить вам новинку с двумя МДФ панелями- Тульскую дверь Б25 НОВИНКИ 2019 Тульская дверь Е4 ОРХИДЕЯ НОВИНКИ 2019 Тульская...
Установка драйвера принтера отказ
Нередки ситуации, когда не устанавливается принтер, хотя система видит, что к компьютеру подсоединилось новое оборудование. Решение такой задачи требует серьезного...
Adblock detector